Vous n’êtes pas connecté.

Dear visitor, welcome to Librejeu.fr - Les forums. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

mercredi 21 mars 2012, 21:51

Problème d'installation sur WinXP

Salut à tout le forum ! :)
Voilà, j'ouvre ce topic car j'ai un problème pour l'installation de DF sur windows XP. J'ai téléchargé la version 0.34.05 sur ce site : http://www.bay12games.com/dwarves/.
Bon, j'ai télécharger puis extrait avec Winrar, et là, surprise, j'ouvre le dossier df_34_05_legacy et je double-click sur DF (Dwarf Fortress), et là message d'erreur qui me dit ceci :" Le point d'entrée de la procédure DecodePointer est introuvable dans la bibliothèque de liaison dynamique KERNEL32.dll."


Voilà, si vous voulez plus de précisions, demandez moi, et j'espère que vous aurez quelque solutions à me donner :)
:ninja:

Satche

Apprenti

Messages: 117

Localisation: Suisse

Travail: Concepteur en multimédia

  • Envoyer un message privé

2

mercredi 21 mars 2012, 23:21

Tu as ouvert l'exécutable ? ("dwarfort.exe" de mémoire)

Rinrynque

Disciple

Messages: 231

Localisation: France, devant mon PC

Travail: étudiant

  • Envoyer un message privé

3

jeudi 22 mars 2012, 12:18

Je ne saurais que te conseiller le Lazy Newb pack si tu rencontre des problèmes, mais à part ça, je sais pas ;)

4

jeudi 22 mars 2012, 17:08

Aïe, je lance une recherche mais aucune trace de dwarfort.exe malheureusement... N'y aurait-il pas un tuto pour installer DF ?

5

jeudi 22 mars 2012, 17:12

Heum , la moi je peut pas t'aider , puisque j'ai telecherger la version SDL , essaye de la télecharger Peut etre que avec la legacy ca marche pas :)

6

jeudi 22 mars 2012, 17:15

Tu peux me donner un lien pour la version SDL stp, je vais voir ça ^^
Par contre, c'est une ancienne version ?

Actoue

Débutant

Messages: 23

Localisation: Tu vois le 3e arrondissement à Paris?Hé bin c'est pas là!

Travail: 4e et concepteur de plan de ferme pour Minecraft.

  • Envoyer un message privé

7

jeudi 22 mars 2012, 17:33

Dans le lien que tu a mit il y a:
SDL: Windows | Mirror 1 | Mirror 2 | Windows (No Music) | Linux | Mac (Intel)
Juste au dessus de Legacy,sinon si tu y arrive pas tu a: http://www.bay12forums.com/smf/index.php?topic=59026.0
Le lazy newb pack ^^

8

jeudi 22 mars 2012, 17:43

Ok, j'ai essayé mais marche pas non plus, il me dit qu'il manque un composant et que la réinstallation peux résoudre le problème...
Donc je réinstalle ! :D


EDIT : Même problème en réinstallant... :cursing:

Si vous avez des solutions ou des précisions à me demander, à vos claviers !!

Actoue

Débutant

Messages: 23

Localisation: Tu vois le 3e arrondissement à Paris?Hé bin c'est pas là!

Travail: 4e et concepteur de plan de ferme pour Minecraft.

  • Envoyer un message privé

9

jeudi 22 mars 2012, 18:04

Tu ne lance pas le jeu directement du fichier winrar?

Satche

Apprenti

Messages: 117

Localisation: Suisse

Travail: Concepteur en multimédia

  • Envoyer un message privé

10

jeudi 22 mars 2012, 18:09

Au point où tu en es, autant essayer ceci: télécharge le fichier pour Mac (toujours SDL).

Il me semble que c'est le même que pour Windows mais avec un fichier bash en plus pour lancer l'exécutable.
Cherche et lance dwarfort.exe.

11

jeudi 22 mars 2012, 18:13

Je ne lance pas le jeu dans l'archive winrar, j’extraie d'abord le dossier x).
Ok, je vais tenter d'installer la version mac.
J'en peux plus de devoir attendre avant d’essayer DF ! ^^

EDIT : Ca ne marche toujours pas, mais n'y aurait-il pas un topic pour expliquer l'installation de DF ?

Actoue

Débutant

Messages: 23

Localisation: Tu vois le 3e arrondissement à Paris?Hé bin c'est pas là!

Travail: 4e et concepteur de plan de ferme pour Minecraft.

  • Envoyer un message privé

12

jeudi 22 mars 2012, 18:45

Pour installer DF tout ce qu'il y a à faire c'est de extraire tout les fichier dans le .zip (ou winrar) dans un fichier choisi et voila on lance Dwarfortress.exe et le jeu se lance,je ne vois pas d'ou peut venir ton problème...

13

jeudi 22 mars 2012, 18:46

Pour ma part selon souvenir j'ai pris le fichier, j'ai décompressé (j'ai 7zip et pas winrar, mais ca ne devrai rien changer)
J'ai placé le dossier dans program files (rangeons!)
et ça marchait.

Sinon, le pack phoebus fonctionne aussi
http://www.bay12forums.com/smf/index.php…4&topic=57557.0

pour win xp, tu télécharge ce fichier: http://dffd.wimbli.com/file.php?id=2431
tu cherches Dwarf Fortress.exe dans le dossier, et tu lance, et ça fonctionne, avec de chouettes graphismes en bonus.



https://sites.google.com/site/dwarffortr…er-et-installer

14

jeudi 22 mars 2012, 18:46

Ton windows XP est à jour?

15

jeudi 22 mars 2012, 18:46

J'ai réussi en installant DF 0.28.181.40d, une ancienne version...
Elle est vraiment moins bien que les plus récentes ?

(EDIT : Je viens de lire vos posts, je vais essayer plutôt vos solutions alors ^^)

16

jeudi 22 mars 2012, 19:30

Le pack Phoebus m'affiche exactement le même problème, et pas de trace de ce "Dwarfortress.exe".
Ce peut-être parce que j'ai winXP sp2 ?

17

jeudi 22 mars 2012, 19:56

Ben normallement , si tu arrive pas a le lancer , soit ton xp est pas a jour ou pas compatible , soit il te manque un truc , Essaye de faire clic droit sur le dwarffortress.exe puis propriété et ensuite dans compatibilité tu devrais essayer des trucs :)

18

jeudi 22 mars 2012, 20:18

Non, même message d'erreur que le premier que je citais...
J'espère que je pourrais quand même jouer à Dwarf Fortress... :'(

Mais sinon, ce n'est pas bien cette version ? DF 0.28.181.40d
La seule qui marche x).

19

jeudi 22 mars 2012, 21:05

bah c'est une vielle version. Tu n'aura pas nombre de nouveautés. Mais c'est étrange que ça ne fonctionne pas chez toi.
tu avais bien essayé celui la? http://www.bay12games.com/dwarves/df_34_05_win.zip

20

jeudi 22 mars 2012, 21:20

raaaaaaa j'ai relu ton premier post, comme quoi il ne faut pas lire trop vite. Tu as un problème dans le kernel32.

Ca viendrait donc de ton pc. (ce qui semble logique, vu que chez nous, ca marche)

fais dans l'ordre:
-un coup d'antivirus (si tu n'en a pas , télécharge avast et lance un grand ménage)
une mise a jour de windows (utiise internet explorer (important!!!) et va sur le site microsoft update.
http://www.update.microsoft.com/

mets ton windows a jour.
(si c'est une copie pirate, bon courage pour passer le genuine, utilise google)

Une fois tout ca fait, réessaie depuis le début.
Normalement la maj de windows devrait avoir fait le ménage dans les dll.

Noter cette discussion